InfraPub 为您找到相关结果 23

Linux Kernel 4.15 正式发布,修补Intel漏掉

Linus Torvalds 于28日宣布发布 Linux 4.15 内核系列,第一个完全针对 Meltdown 和 Spectre 进行修补的版本。 Linux Kernel 4.15 进行了为期八周的开发,内核开发者花费大量时间重新设计了内核,并针对本月早些时候公开披露的两个熔断(Meltdown)和幽灵(Spectre)进行了修补。 Linux kernel 4.15 是第一个针对 Meltdown 和 Spectre 进行完全修补的内核系列,但是仅适用于 x86 和 PowerPC(PPC)体系结构。 如果您使用的是带有英特尔或 AMD 处理器的 GNU / Linux 发行版,那么仍有可能会遇到Meltdown 和 Spectre 恶意攻击。 该版本提供对...阅读全文

博文 2018-01-29 11:34:21 debian.cn

Ubuntu 16.04 LTS 收到重大内核更新:共修复39处漏洞

在为32位/64位设备和树莓派2发布Ubuntu 17.10(Artful Aardvark)系列的重大核心更新之后,Canonical今天再次为Ubuntu 16.04 LTS(Xenial Xerus)发布重大内核更新,共计修复39处。 Ubuntu 16.04是长期支持版本,此外包括 Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, Ubuntu Kylin和Ubuntu Studio在内的官方flavor版本也获得更新。 本次修复的中,危害最严重的就是Linux Kernel USB over IP部署,允许黑客远程攻击系统导致崩溃或者通过DoS攻击导致大量消耗内存。Ubuntu 16.04 LTS目前的Linux内核版本为4.4,此外...阅读全文

博文 2018-04-10 10:04:39 debian.cn

Debian资源库已加入Spectre、Meltdown漏洞检查器

影响几乎所有现代处理器的“幽灵”(Spectre)和“熔毁”(Meltdown)的余波尚未散尽,软硬件厂商仍在携手努力给平台打补丁。如果你正在运行 Debian GNU/Linux 环境,并且希望检查系统是否存在严重的,那么现在已经可以从 Debian 资源库下载 Spectre 和 Meltdown 缓和检查器了。Debian 项目团队表示,用户只需输入单行命令,即可完成该脚本的安装。 本月早些时候,外媒 Softpedia 曾发布过一篇面向 Linux PC 用户的安全检查教程。不过现在,Debian GNU/Linux 用户只需打开终端,并输入如下命令行: sudo apt-get install spectre-meltdown-checker 然后运行...阅读全文

博文 2018-01-31 10:28:44 debian.cn

Linux kernel tcp_ipv6.c拒绝服务漏洞 CVE-2016-8645

发布日期:2016-11-24 更新日期:2016-11-29 受影响系统:Linux kernel 4.0 ~ Linux kernel < 4.8.7 描述: BUGTRAQ ID: 94264 CVE(CAN) ID: CVE-2016-8645 Linux kernel 4.8.10之前版本,TCP栈错误处理了skb截断,在实现上存在,本地攻击者通过构造的应用,可造成拒绝服务。 <* 来源:Marco Grassi *> 建议: 厂商补丁: Linux ----- 目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载: http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.10 https...阅读全文

Ubuntu发布重要更新将修复九个漏洞

(CoW),这影响了所有受支持的Ubuntu版本和他们的衍生版。 Linux内核的关联数组实现也是一个问题,它有时并没有正确地处理添加一个新条目,以及在Linux内核的GTCO digitizer USB驱动程序中发现的一个越界阅读,它影响了Ubuntu 17.10和Ubuntu 16.04 LTS版本。 修正了Linux内核驱动程序子系统中的争用情况,这个更新只影响Ubuntu 17.04。更新地址解决了Linux内核的PowerPC KVM实现中的空指针引用错误和密钥管理子系统中的争用情况,仅影响Ubuntu 17.10。 建议所有Ubuntu用户尽快更新安装 Andrey Konovalov在Linux内核的USB子系统中发现了另一个,该子系统无法正确验证USB BOS元数据,从而影...阅读全文

博文 2017-12-20 11:31:08 debian.cn

Adobe 正式宣布放弃 Flash

今天,Adobe 正式宣布将放弃 Flash,而相关技术会在 2020 年底全部退役。 在这份公告中,Adobe 强调,在未来三年时间里,苹果、微软、谷歌等将分阶段停止为 Flash 提供技术支持。在 2020 年过后,Adobe 将停止为 Flash 发布更新,网络浏览器将不再支持该技术。这些公司正在鼓励开发者为其软件改用现代编程标准。 Flash 技术是在 20 多年以前诞生的,曾是开发者最青睐的软件之一,被用于开发游戏、视频播放器和可在多个网络浏览器上运行的应用,但它的弊端也是足够明显,存在大量的严重,让 Mac 和 PC 用户暴露于危险之中。 其实在这之前,苹果、谷歌、微软等公司都已经很少触及 Flash 技术,所以业界并不担心这样的技术淘汰。...阅读全文

Debian 10.5 发布,修复 BootHole 安全漏洞

Debian 10.5 已发布,这是 Debian 10 “Buster” 的第五个稳定版更新,修复了部分安全问题和 bug。 其中最值得关注的是,此版本提供了必要的补丁来解决最近的 GRUB2 UEFI SecureBoot “BootHole” 。因此现在 BootHole 应该可以在 Debian 10.5 中得到解决,同时也不会出现当时缓解漏洞后仍有困扰部分 RHEL/CentOS 用户的启动问题。 除了解决 BootHole 问题之外,Debian 10.5 还更新了 ClamAV 防病毒软件、对 file-roller 的安全修复和其他细小的修复,对 fwupdate 和其他软件包使用加密的 Debian 签名密钥、修复 Jigdo 中的 HTTPS 支持问题、升级...阅读全文

博文 2020-08-02 20:24:51 debian.cn

Debian 10.4 Buster发布 请尽快更新

作为 Debian 10“Buster”系列发行版的第四个稳定更新,Debian 10.4 主要修复了安全性问题。维护团队希望已经用上 Debian 10 的设备能够尽快部署安全修复程序,更新过程很是简单。另有针对严重问题的一些调整,公告详情可移步至官网查看。 据悉,Debian 10.4 只是更新了 Debian 10 自带的某些软件包,所以大家不用急着扔掉旧版安装介质。安装完成后,再通过自动更新组件来获取即可。 新版中修复了 libssh 的一个特定,0.8.9 和 0.9.4 之前的 libssh 版本都受到影响。若未完全初始化连接、且系统尝试清理,则该漏洞可导致客户端或服务器完全崩溃。 此外,Debian 10.4 移除了一些软件包,比如因为 Hotmail...阅读全文

博文 2020-05-10 21:59:29 debian.cn

故意泼脏水?AMD官方回应Zen安全漏洞

来自以色列的安全机构CTS-Labs突然曝出猛料,声称AMD Zen架构处理器存在四组12个高位,涉及Ryzen、EPYC全线产品。AMD第一时间对此发表了一份官方声明。 “我们刚刚收到一家名为CTS-Labs的公司的报告,声称我们的特定处理器产品可能存在。我们正在积极进行调查和分析。这家公司AMD从未听闻,而且不同寻常的是,这家安全机构直接将自己的发现公布给了媒体,却没有给AMD合理的时间调查和解决问题。安全是AMD的首要职责,我们持续努力确保我们客户的安全,应对新的安全威胁。如有后续进展我们会第一时间公告。” 可以看出,由于事发突然,特别是这些漏洞发现并没有按照行业惯例提前通知并给予90天的静默期,AMD被打了个措手不及,目前还无法完全证实这些漏洞的真伪。 即便是真的存...阅读全文

Tails 4.4 发布,能你隐身的发行版

Tails 4.4 稳定版已发布,更新内容包括升级应用程序和修复。此版本中修复了在 Tails 4.3 中发现的许多安全问题,例如影响 OS 组件,以及 Tor Browser 和 Mozilla Thunderbird 等预装应用程序的漏洞。 该版本已将内核升级至 Linux Kernel 5.4.19,改进对显卡、无线网卡等较新硬件的支持。另外还修复了一些 Realtek RTL8822BE 和 RTL8822CE 芯片组的 Wi-Fi 接口造成的问题,团队还表示如果从 Tails 4.1 起使用 WiFi 时出现问题,请告知他们问题是否已解决。 最后,Tails 4.5 计划于4月7日发布。 下载地址:tails-amd64-4.4.iso (1,098MB...阅读全文

Debian已着手部署补丁:修复WPA2安全漏洞

昨天最令人感到惊讶和担忧的就是,服役超过13年的WPA2加密协议已经被攻破,意味着在你家或办公室 Wi-Fi 物理覆盖范围内的攻击者,都可以向破解并发动入侵,监听你的网络活动、拦截不安全或未加密的数据流。针对本次严重的,包含Debian Linux在内的诸多系统厂商已经着手部署安全补丁,以便于提供更安全的上网环境。 该补丁已经修复了Common Vulnerabilities and Exposures(CVE)的如下漏洞 CVE-2017-13077 CVE-2017-13078 CVE-2017-13079 CVE-2017-13080 CVE-2017-13081 CVE-2017-13082 CVE-2017-13086 CVE-2017-13087 CVE-2017...阅读全文

博文 2017-10-17 13:32:27 debian.cn

Debian 9修复18个重要的Linux 4.9 LTS内核安全漏洞

Debian 项目近日发布了针对 Debian GNU/Linux 9 “ Stretch ” 系列操作系统新的 Linux 内核安全更新,修复了最近发现的几个漏洞 。 根据最新的 DSA 4073-1 Debian 安全通报,在 Debian GNU/Linux 9 “ Stretch ” 操作系统的 Linux 4.9 LTS 内核中,共有 18 个,其中包括信息泄露,提权升级和拒绝服务等问题。 通报显示,在 Linux 内核的 DCCP 实现、dvb-usb-lmedm04 驱动程序、hdpvr 媒体驱动程序、扩展 BPF 验证程序、netfilter 子系统、netlink 子系统、xt_osf 模块、USB 核心以及 IPv4 原始套接字实现都存在问题。另外,Linux...阅读全文

博文 2017-12-27 23:31:06 debian.cn

谷歌安全博客披露“ 英特尔内核漏洞 ”更多细节

去年的时候,Google 旗下 Project Zero 团队发现了一个由 CPU “ 预测执行 ” 导致的严重,而它也是一项被大多数现代处理器使用的性能优化方案。根据研究人员 Jann Horn 的演示,恶意攻击者可借此读取不该被它访问到的系统内存。某个未经授权的一方,可能在系统内存中读取到一些敏感信息,比如密码、加密密钥、或者在应用程序中打开的其它机密信息。 测试还表明,在一台虚拟机上发起的攻击,甚至能够访问到主机的物理内存。基于此,还可以获取在同一主机上、不同虚拟机的内存读取访问。 该漏洞影响许多 CPU,包括来自英特尔、AMD、ARM 的芯片,以及搭配运行的设备和操作系统。在获悉这种新型攻击的第一时间,谷歌安全和产品开发团队就积极动员了起来,以保护自家系统和用户数据。 万幸...阅读全文

博文 2018-01-06 23:38:25 debian.cn

Systemd 曝出三个漏洞 大部分 Linux 发行版易受攻击

Linux 系统与服务管理工具 Systemd 被曝存在 3 大漏洞,影响几乎所有 Linux 发行版。Systemd 是 Linux 系统的基本构建块,它提供了对系统和服务的管理功能,以 PID 1 运行并启动系统的其它部分。目前大部分 Linux 发行版都以 Systemd 取代了原有的 System V。 安全公司 Qualys 近日发布报告称其发现 Systemd 中存在 3 个,并且这些漏洞已经存在 3 到 5 年时间。 3 个漏洞已经收录到 CVE,分别是内存损坏漏洞 CVE-2018-16864 与 CVE-2018-16865、信息泄露漏洞 CVE-2018-16866。其中,CVE-2018-16864 于 2013 年 4 月引入(systemd v203),并...阅读全文

博文 2019-01-15 10:56:33 debian.cn

25岁的Flash正式被弃用

其系统。” Adobe于2017年首次宣布了停止使用Flash的计划。“多年来,HTML5,WebGL和WebAssembly等开放标准已经不断成熟,可以作为Flash内容的可行替代方案。” 如果电脑上还有Flash,可以删了。多年来,由于众多使Mac和PC用户面临恶意软件和其他风险,Flash声名狼借,迫使微软和苹果这样的供应商不懈地努力以应对安全修补程序。 乔布斯算是反Flash的先锋人物了 在“反Flash”这件事上,苹果公司的联合创始人兼前首席执行官乔布斯(Steve Jobs)算是先锋人物,在2010年的公开信中就批评Adobe的软件可靠性,安全性和性能不佳。乔布斯还说,苹果“不能由第三方决定是否以及何时将我们的新增功能提供给我们的开发人员。” 因为这天早有预期,所以...阅读全文

博文 2021-01-13 08:49:17 debian.cn

英特尔放出Linux微代码以修复Meltdown和Spectre漏洞

近日,Intel发布了最新版本的Linux处理器微代码数据文件,而这个补丁文件能够修复Intel CPU中的Spectre以及Meltdown漏洞。广大用户可以使用微代码文件来修复操作系统中目前已知的Intel CPU,而无需在计算机中执行BIOS更新。 根据Intel微代码下载页面所提供的介绍,Intel此次发布了40种不同版本(针对Linux)的补丁代码,可适用于多款不同型号的Intel处理器。 下面给出的就是Intel官方网站列出的处理器支持型号。大家可以参考下列表格以及cpu-world.com网站上的CPU信息来寻找合适自己处理器的补丁版本。注意,下列表格中的CPU版本号为十六进制值(例如(06-3c-03:32)),你可以在cpu-world.com寻找到相匹配的处理器...阅读全文

博文 2018-01-17 23:26:58 debian.cn

Metasploit Framework 5.0 发布 最流行的渗透测试框架

Metasploit 项目是一个旨在提供信息的计算机安全项目,可以协助安全工程师进行渗透测试(penetration testing)及入侵检测系统签名开发。Metasploit 项目知名的功能还包括反取证与规避工具,其中的某些工具已经内置在 Metasploit Framework 里面。 Metasploit Framework —— 一套针对远程主机进行开发和执行 “exploit代码” 的工具,是 Metasploit 的最为知名的子项目。Metasploit Framework 全称为 The Metasploit Framework,简称 MSF。这是一个渗透测试的框架,不是一个直接的渗透测试攻击软件。Metasploit 作为全球最受欢迎的工具,不仅仅是因为它的方便性...阅读全文

博文 2019-01-15 13:37:28 debian.cn

Harbor 1.9 发布:新增多项企业级功能

Policy) 目前,Harbor 会对某些镜像的运行加以限制,即那些被安全策略进行了漏洞(CVE) 扫描,且结果符合限制条件的镜像。又是为了对的某些 CVE 的情况进行例外处理,例如,忽略低严重性 CVE 或当前无解决方案的 CVE,1.9 为管理员引入了一项功能,使其可以创建一个 CVE 白名单,从而允许这些镜像在有限的时间段内运行,而不管是否具有特定 CVE 。系统管理员可以创建一个对所有项目都有效的全局 CVE 白名单,而项目管理员则可以在单个项目级别进一步细化此白名单。 内容复制的改进 1.8 版推出了在 Harbor 与其他 Registry(例如 Docker Hub 和 Huawei Cloud)之间进行跨 Registry 内容复制的功能,而 1.9 版对这些功能进行了扩展...阅读全文

博文 2019-10-09 12:12:04 debian.cn

Linux 基金会董事 Jim Zemlin:全球开源可持续增长将带来更多价值

Linux 安全性、项目管理及与其他领域结合发展 (1)近期勒索病毒肆虐全球,安全性方面,总会有人拿Linux 与Windows 相比。而 Jim 则不认可这种比较。他认为开发任何一个比较复杂的软件系统,都难免会有。 从安全性的角度来看,在 Linux 开发过程中会启动 CoreOS 项目,对所有代码进行同行评估,成千上万个开源开发者参与其中,对所有代码的安全性进行审议。由此希望通过审计的代码是最安全的,开发出的软件是安全可靠的。 “总而言之,安全是我们的任何项目的重中之重,非常关注与重视的一个问题,包括 Linux 的所有项目” (2)Linux 作为超大规模的项目,又是如何进行管理的呢? “每天我们贡献的代码数量会达到 1 万行,从中抽取 5 千行,还有1800行代码每天都是精心修改的...阅读全文

博文 2021-01-28 17:50:33 debian.cn

TLS1.3 正式版发布 — 特性与开启方式科普

。TLS1.2具有很强的可配置性,因此一些有的站点为兼容老版本的浏览器而没有关闭那些旧的属性。 TLS1.3信奉“少即是多”哲学,取消了对一些老旧而衰弱的加密方式的支持。这意味着你无法打开那些潜在的漏洞。TLS1.2中原有的大量特性都被删除了,其中大部分特性与那些著名的攻击有关,这些特性包括: RSA 密钥传输 —— 不支持前向安全性 CBC 模式密码 —— 易受BEAST和Lucky 13攻击 RC4 流密码 —— 在HTTPS中使用并不安全 SHA-1 哈希函数 —— 建议以SHA-2取而代之 任意 Diffie-Hellman 组 —— CVE-2016-0701漏洞 输出密码——易受 FREAK 和 LogJam攻击 TLS1.3 消除了旧版本中糟糕的加密方式,同时降低了旧的攻击方式对其...阅读全文

博文 2018-08-14 14:40:05 debian.cn

改善 Debian Linux 软件包管理的七款工具

了十个速度最快的镜像,然后把它们写入到你的软件包源列表。apt-spy执行类似的功能。 3. apt-transport-tor 你可能也知道了,Tor是一款匿名浏览工具。然而,即便你注重安全,下载软件包有可能让别人跟踪你的活动,进而一路跟踪你的系统。 apt-transport-tor让你可以堵住这个,它通过Tor来传输软件包管理指令。 2. cron-apt 如果你注重安全,或者只想要最新软件包,cron-apt可以帮助你确保版本最新。顾名思义,cron-apt可以为你的系统调度定期下载,并通知可用更新版。用户往往每天更新一次。 然而要注意:cron-apt下载但不安装更新的软件包。这个限制是有意设置的,因为在无人照看的情况下安装一切会导致系统问题。检查什么更新版可用后,你可以手...阅读全文

博文 2021-01-28 17:50:21 debian.cn

HTTP状态码详解

能够处理的范围。此种情况下,服务器可以关闭连接以免客户端继续发送此请求。 如果这个状况是临时的,服务器应当返回一个 Retry-After 的响应头,以告知客户端可以在多少时间以后重新尝试。 414 请求的URI 长度超过了服务器能够解释的长度,因此服务器拒绝对该请求提供服务。这比较少见,通常的情况包括: 本应使用POST方法的表单提交变成了GET方法,导致查询字符串(Query String)过长。 重定向URI “黑洞”,例如每次重定向把旧的 URI 作为新的 URI 的一部分,导致在若干次重定向后 URI 超长。 客户端正在尝试利用某些服务器中存在的攻击服务器。这类服务器使用固定长度的缓冲读取或操作请求的 URI,当 GET 后的参数超过某个数值后,可能会产生缓冲区溢出,导致任...阅读全文

博文 2021-01-28 17:50:11 debian.cn