Gitlab 从 12.1 版本开始不再支持 MySQL

· · 339 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

Gitlab 官方 宣布 ,将从 12.1 版本开始不再支持 MySQL 数据库。早在 2017 年 7 月,Gitlab 就计划将弃用对 MySQL 的支持。而目前这个决定将从 12.1 版本开始。

Gitlab 从 12.1 版本开始不再支持 MySQL

官方列出几个 MySQL 不能满足 Gitlab 需求的地方:

为了解决上面这些问题,Gitlab 创建了许多专门针对 MySQL 的代码。 在某些情况下,这导致合并请求的复杂性要高一倍,因为它们必须支持第二个数据库后端。 创建和维护这些代码会消耗我们的循环时间和速度,并且会降低我们的迭代值。

它也使我们变慢,因为我们的 CI 系统将运行我们的测试套件两次,每个后端一次。 删除对 MySQL 的支持可缩短 CI 作业的时间,并降低成本。 这些成本最终变得相当可观。

总而言之,Gitlab 觉得同时支持 MySQL 和 PostgreSQL 两个数据库,让开发团队觉得烦不胜烦。

此外据 Gitlab 调查发现,使用 MySQL 的多是 11 版本之前的用户。

所以,如果你想升级到 Gitlab 12.1 版本的话,那么你老的 MySQL 数据库可能会让你比较痛苦,可以参考官方的 移植指南 迁移至 PostgreSQL 。

关注本站微信公众号(和以上内容无关)InfraPub ,扫码关注:InfraPub

339 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传